계산기로 바로가기
/24
서브넷 계산기
인터넷 역사•9분 소요•2026년 10월 8일

IPv4 및 IPv6 역사: 인터넷 프로토콜의 진화와 미래

ARPANET과 RFC 791부터 IPv4 주소 고갈 사태, 전 세계적인 IPv6 전환까지 인터넷 프로토콜의 역사를 살펴봅니다.

IP
작성자: 네트워크 엔지니어링 팀

1. ARPANETの起源とIPv4の誕生(1973–1981)

Vinton Cerf氏とRobert Kahn氏がTCP/IPを考案し、1981年9月にJon Postel氏がRFC 791を策定。1983年1月1日(Flag Day)にARPANETがTCP/IPへと完全移行しました。

2. なぜ32비트だったのか?

RFC 791の32비트(約43億주소)は、当時の研究ネットワーク規模では無限と信じられていました。

3. クラス制時代と枯渇の危機(1981–1993)

固定クラス配分によりクラスBの取得が殺到し、深刻な枯渇危機に直面しました。

4. 延命策: CIDR、NAT、そしてRFC 1918(1993–1996)

  1. CIDR (RFC 1519 - 1993): クラス廃止とルート集約。
  2. プライベートIP空間 (RFC 1918 - 1996): 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16。
  3. NAT (RFC 1631 - 1994): 1つのグローバルIPを複数ホストで共有。

5. IPv5はどうなったのか?

Version Bit Nibble:
0100 (Binary 4) = IPv4 (RFC 791)
0101 (Binary 5) = ST / ST-II (Internet Stream Protocol - RFC 1190 & RFC 1819)
0110 (Binary 6) = IPv6 (RFC 2460 & RFC 8200)

バージョン5はリアルタイム音声伝送プロトコル ST / ST-II (RFC 1190) に割り当てられていたため、次世代規格は直接 IPv6 と命名されました。

6. IPv6の標準化(1994–1998)

Steve Deering氏らの提案を基に策定され、2017年の RFC 8200 で正式な인터넷標準となりました。

7. IPv4주소枯渇年表

Timeline of IPv4 Exhaustion Milestones:
• Feb 3, 2011:  IANA distributes the final five /8 blocks to the 5 RIRs.
• Apr 15, 2011: APNIC (Asia-Pacific) exhausts standard free pool.
• Sep 14, 2012: RIPE NCC (Europe & Middle East) exhausts free pool.
• Jun 10, 2014: LACNIC (Latin America & Caribbean) exhausts free pool.
• Sep 24, 2015: ARIN (North America) exhausts free pool.
• Nov 25, 2019: RIPE NCC allocates its very last remaining IPv4 block.

8. 現在と未来: デュアルスタックとIPv6-Only

モバイルキャリアやハイパースケーラーは純粋なIPv6-Onlyトポロジーへと移行し、464XLAT (RFC 6877) でレガシーIPv4を収容しています。

태그:#IPv4 역사#IPv6 발전#ARPANET#RFC 791#Dual-Stack

⚡서브넷을 계산할 준비가 되셨나요?

32비트 레지스터 분석, CIDR 차트 및 VPC 분할 기능이 포함된 대화형 IPv4/IPv6 서브넷 계산기를 사용해 보세요.

서브넷 계산기 열기 →

관련 엔지니어링 가이드