계산기로 바로가기
/24
서브넷 계산기
인터넷 표준•7분 소요•2026년 10월 8일

RFC와 IANA란 무엇인가? 인터넷 표준 완벽 가이드

인터넷 표준화 프로세스를 이해하세요. RFC 문서, IETF의 역할 및 IANA의 글로벌 IP 주소 할당 체계.

IP
작성자: 네트워크 엔지니어링 팀

1. 世界の인터넷を支える見えない規約

IETF のオープン標準と IANA のグローバル統括が世界的な相互運用性を保証しています。

2. RFC(Request for Comments)とは?

1969年4月、Steve Crocker氏がRFC 1を執筆。「コメント求む」という謙虚な名称が、上下関係のない協調精神の礎となりました。

「大まかな合意と動くコード」

David Clark氏の名言: 「王や大統領、投票を信じない。大まかな合意と動くコードを信じる。」

3. RFCのカテゴリと標準化プロセス

4. エンジニア必須の歴史的RFC一覧

Foundational RFCs of Modern Networking:
• RFC 791 (1981):  Internet Protocol (IPv4) Specification
• RFC 793 (1981):  Transmission Control Protocol (TCP)
• RFC 1918 (1996): Address Allocation for Private Internets (10/8, 172.16/12, 192.168/16)
• RFC 2460 / 8200: Internet Protocol, Version 6 (IPv6) Specification
• RFC 2616 / 7230 / 9110: Hypertext Transfer Protocol (HTTP/1.1 & HTTP Semantics)
• RFC 3021 (2000): Using 31-Bit Prefixes on IPv4 Point-to-Point Links
• RFC 4291 / 5952: IPv6 Addressing Architecture & Recommendation for IPv6 Text Representation
• RFC 8305 (2017): Happy Eyeballs v2 (Better Dual-Stack Connectivity)

5. IANA(Internet Assigned Numbers Authority)とは?

Jon Postel氏によって創設され、ドメイン名(DNSルート)、番号資源(IP/ASN)、プロトコルパラメータを管理します。

6. グローバルIP주소分配階層

            [ IANA ]
     (Global Numbers Authority)
                 │
  ┌──────────────┼──────────────┬──────────────┬──────────────┐
  ▼              ▼              ▼              ▼              ▼
[ARIN]       [RIPE NCC]      [APNIC]        [LACNIC]      [AFRINIC]
(N. America)  (Europe/ME)   (Asia-Pacific) (Latin America) (Africa)
  │              │              │              │              │
  └──────────────┴──────────────┼──────────────┴──────────────┘
                                ▼
                 [ Internet Service Providers / ISPs ]
                                ▼
                 [ Enterprise Networks & End Users ]

7. RFC内の「IANA Considerations」

新しい規格を策定する際は、IANAが管理するテーブルに登録すべきポート番号やフラグを明記します。

8. アーキテクトへの示唆

オープン標準に基づいた設計はベンダーロックインを排除し、強靭なインフラを確立します。

태그:#RFC#IANA#IETF#표준#IP 할당

⚡서브넷을 계산할 준비가 되셨나요?

32비트 레지스터 분석, CIDR 차트 및 VPC 분할 기능이 포함된 대화형 IPv4/IPv6 서브넷 계산기를 사용해 보세요.

서브넷 계산기 열기 →

관련 엔지니어링 가이드