हाम्रो बारेमा
हाम्रो बारेमा — IPv4 र IPv6 नेटवर्कहरूका लागि ब्राउजरमै तुरुन्त काम गर्ने उच्च शुद्धताको सबनेट क्याल्कुलेटर।
01 // ARCHITECTURESubnetting Architecture & In-Browser Bitwise Engine (नेपाली)
Subnetting partitions an IP network into isolated broadcast domains. Computing client-side ensures confidential IP designs remain 100% private.
Delivering instant, zero-latency bitwise calculation directly in the browser with full client confidentiality.
02 // CORE PILLARSगणितीय शुद्धता, RFC अनुपालन र शून्य-लग गोपनीयता
⚡ शून्य-विलम्बता इन्जिन
WebAssembly र JavaScript बिटवाइज अपरेटरहरूको साथ स्थानीय रूपमा ब्राउजरमै सब-मिलिसेकेन्ड गणनाहरू।
🔒 शून्य-लग ग्यारेन्टी
तपाईंको निजी IP ठेगाना योजनाहरू कहिल्यै ब्राउजर बाहिर जाँदैनन् वा बाह्य सर्भरमा पुग्दैनन्।
📜 RFC मापदण्ड अनुसार
RFC 791, RFC 1519, RFC 3021, RFC 4291 र RFC 5952 को पूर्ण पालना।
03 // STANDARDSआधिकारिक IETF र RFC प्राविधिक विशिष्टताहरू
| मानक | विशिष्टता शीर्षक | कार्यान्वयन दायरा |
|---|---|---|
| RFC 1918 | निजी इंटरनेट के लिए पता आवंटन | क्लास A (10/8), क्लास B (172.16/12), क्लास C (192.168/16) |
| RFC 3021 | IPv4 पॉइंट-टू-पॉइंट लिंक पर 31-बिट उपसर्ग | बिना किसी ब्रॉडकास्ट ओवरहेड के प्रति लिंक 2 उपयोग योग्य होस्ट |
| RFC 4291 | आईपी संस्करण 6 एड्रेसिंग आर्किटेक्चर | 128-बिट उपसर्ग दायरा, ग्लोबल यूनिकॉस्ट, /64 SLAAC सीमा |
| RFC 4632 | क्लासलेस इंटर-डोमेन रूटिंग (CIDR) | VLSM के साथ /0 से /32 तक पूर्ण उपसर्ग आवंटन |
निःशुल्क IPv4 र IPv6 सबनेट क्याल्कुलेटर
IPv4 र IPv6 नेटवर्कहरूका लागि ब्राउजरमै तुरुन्त काम गर्ने उच्च शुद्धताको सबनेट क्याल्कुलेटर।