କ୍ୟାଲକୁଲେଟରକୁ ଯାଆନ୍ତୁ
/24
ସବନେଟ୍ କାଲକୁଲେଟର
ଇଣ୍ଟରନେଟ୍ ଇତିହାସ•9 ମିନିଟ୍ ପଢ଼ିବା•୮ ଅକ୍ଟୋବର ୨୦୨୬

IPv4 ଏବଂ IPv6 ର ଇତିହାସ: ବିବର୍ତ୍ତନ ଏବଂ ଭବିଷ୍ୟତ

ARPANET ଏବଂ RFC 791 ରୁ ଠିକଣା ଅଭାବ ଏବଂ ବିଶ୍ୱବ୍ୟାପୀ IPv6 କାର୍ଯ୍ୟକାରିତା ପର୍ଯ୍ୟନ୍ତ ଇତିହାସ।

IP
ଲେଖକ: ନେଟୱାର୍କ ଇଞ୍ଜିନିୟରିଂ ଟିମ୍

1. ARPANET ଏବଂ IPv4 ର ଆରମ୍ଭ (୧୯୭୩–୧୯୮୧)

୧୯୭୦ ଦଶକରେ ଭିଣ୍ଟ ସର୍ଫ୍ ଏବଂ ବବ୍ କାନ୍ TCP/IP ତିଆରି କରିଥିଲେ, ଯାହାକୁ ସେପ୍ଟେମ୍ବର ୧୯୮୧ ରେ RFC 791 ମାଧ୍ୟମରେ ଜନ୍ ପୋଷ୍ଟେଲ୍ ପ୍ରମାଣିତ କରିଥିଲେ।

2. IPv4 ପାଇଁ ୩୨-ବିଟ୍ କାହିଁକି ବଛାଗଲା?

RFC 791 ଠିକଣା ପାଇଁ ୩୨ ବିଟ୍ ନିର୍ଦ୍ଧାରଣ କରିଥିଲା, ଯାହା ୪.୨୯ ବିଲିୟନ ଅନନ୍ୟ ଠିକଣା ପ୍ରଦାନ କରିଥିଲା।

3. କ୍ଲାସଫୁଲ୍ ଯୁଗ ଏବଂ ଠିକଣା ସଙ୍କଟ (୧୯୮୧–୧୯୯୩)

କ୍ଲାସ୍ A, B, C ଆଧାରିତ ବଣ୍ଟନ ଯୋଗୁଁ କ୍ଲାସ୍ B ଶୀଘ୍ର ସରିଗଲା ଏବଂ ରାଉଟିଂ ଟେବୁଲ୍ ବହୁତ ବଡ଼ ହୋଇଗଲା।

4. ସମୟ ବଞ୍ଚାଇବା: CIDR, NAT ଏବଂ RFC 1918 (୧୯୯୩–୧୯୯୬)

  1. CIDR (RFC 1519): ନିର୍ଦ୍ଦିଷ୍ଟ ସୀମା ଉଠାଇ ଭେରିଏବଲ୍ ଲେନ୍ଥ ସବନେଟ୍ ମାସ୍କିଂ (VLSM) ଆରମ୍ଭ କଲା।
  2. ଘରୋଇ ଆଇପି ଠିକଣା (RFC 1918): ଆଭ୍ୟନ୍ତରୀଣ ବ୍ୟବହାର ପାଇଁ 10.0.0.0/8, 172.16.0.0/12 ଏବଂ 192.168.0.0/16 ସଂରକ୍ଷିତ କଲା।
  3. NAT (RFC 1631): ଗୋଟିଏ ପବ୍ଲିକ୍ ଆଇପି ବହୁତ ଡିଭାଇସ୍ ମଧ୍ୟରେ ଅଂଶୀଦାର କରିବାକୁ ଅନୁମତି ଦେଲା।

5. IPv5 ପ୍ରୋଟୋକଲ୍ ସହିତ କ’ଣ ହେଲା?

ସଂସ୍କରଣ ନମ୍ବର ୫ ପରୀକ୍ଷାମୂଳକ Internet Stream Protocol (ST/ST-II) ପାଇଁ ରଖାଯାଇଥିଲା, ତେଣୁ ପରବର୍ତ୍ତୀ ପ୍ରୋଟୋକଲ୍ ର ନାମ IPv6 ରଖାଗଲା।

Version Bit Nibble:
0100 (Binary 4) = IPv4 (RFC 791)
0101 (Binary 5) = ST / ST-II (Internet Stream Protocol - RFC 1190 & RFC 1819)
0110 (Binary 6) = IPv6 (RFC 2460 & RFC 8200)

6. IPv6 ମାନକୀକରଣ (୧୯୯୪–୧୯୯୮)

IETF ୧୯୯୮ ରେ RFC 2460 ଏବଂ ୨୦୧୭ ରେ RFC 8200 ରେ IPv6 କୁ ସମ୍ପୂର୍ଣ୍ଣ ଇଣ୍ଟରନେଟ୍ ମାନକ ଭାବେ ଘୋଷଣା କଲା।

7. IPv4 ଠିକଣା ସରିଯିବାର ଗୁରୁତ୍ୱପୂର୍ଣ୍ଣ ମାଇଲଖୁଣ୍ଟ

Timeline of IPv4 Exhaustion Milestones:
• Feb 3, 2011:  IANA distributes the final five /8 blocks to the 5 RIRs.
• Apr 15, 2011: APNIC (Asia-Pacific) exhausts standard free pool.
• Sep 14, 2012: RIPE NCC (Europe & Middle East) exhausts free pool.
• Jun 10, 2014: LACNIC (Latin America & Caribbean) exhausts free pool.
• Sep 24, 2015: ARIN (North America) exhausts free pool.
• Nov 25, 2019: RIPE NCC allocates its very last remaining IPv4 block.

8. ବର୍ତ୍ତମାନ ଏବଂ ଭବିଷ୍ୟତ: ଡୁଆଲ୍-ଷ୍ଟାକ୍ ଏବଂ କେବଳ-IPv6

ମୋବାଇଲ୍ ଅପରେଟର ଏବଂ କ୍ଲାଉଡ୍ ଡାଟାସେଣ୍ଟରଗୁଡ଼ିକ 464XLAT ମାଧ୍ୟମରେ ବିଶୁଦ୍ଧ IPv6-Only ନେଟୱାର୍କ ପରିଚାଳନା କରୁଛନ୍ତି।

ଟ୍ୟାଗ୍:#IPv4 ଇତିହାସ#IPv6 ବିକାଶ#ARPANET#RFC 791#Dual-Stack

⚡ସବନେଟ୍ ଗଣନା କରିବାକୁ ପ୍ରସ୍ତୁତ ଅଛନ୍ତି କି?

32-ବିଟ୍ ରେଜିଷ୍ଟର ବିଶ୍ଳେଷଣ ଏବଂ CIDR ଚାର୍ଟ ସହିତ ଆମର ଇଣ୍ଟରାକ୍ଟିଭ୍ ସବନେଟ୍ କ୍ୟାଲକୁଲେଟର୍ ବ୍ୟବହାର କରନ୍ତୁ।

ସବନେଟ୍ କ୍ୟାଲକୁଲେଟର୍ ଖୋଲନ୍ତୁ →

ସମ୍ବନ୍ଧିତ ଇଞ୍ଜିନିୟରିଂ ଗାଇଡ୍