المهمة والهندسة
من نحن
تعرف على فلسفتنا الهندسية ومحرك الحساب الفوري في المتصفح والامتثال لمعايير RFC.
01 // ARCHITECTUREما هو تقسيم الشبكات ولماذا نستخدم محرك حساب محلي؟
تقسيم الشبكات هو تجزئة شبكة IP منطقياً إلى نطاقات بث معزولة لحماية البيانات ومنع استهلاك عناوين IP.
حسابات دقيقة فورية داخل المتصفح دون إرسال بيانات شبكتك الحساسة لأي خوادم خارجية.
02 // CORE PILLARSالدقة الرياضية، الامتثال لمعايير RFC والخصوصية بدون سجلات
⚡ محرك فائق السرعة بزمن استجابة فوري
حسابات فورية في أجزاء من المللي ثانية يتم تنفيذها محلياً داخل المتصفح عبر WebAssembly وعمليات البت.
🔒 ضمان الخصوصية وعدم تسجيل البيانات
مخططات عناوين IP الخاصة بك لا تغادر متصفحك أبداً ولا يتم إرسالها إلى أي خوادم خارجية.
📜 مطابقة كاملة لمعايير IETF RFC
التزام تام بالمواصفات الفنية القياسية RFC 791 وRFC 1519 وRFC 3021 وRFC 4291 وRFC 5952.
03 // STANDARDSالمواصفات الفنية الرسمية لـ IETF و RFC
| المعيار | عنوان المواصفة | نطاق التنفيذ |
|---|---|---|
| RFC 1918 | Asignación de Direcciones para Redes Privadas | Clase A (10/8), Clase B (172.16/12), Clase C (192.168/16) |
| RFC 3021 | Prefijos de 31 bits en Enlaces Punto a Punto IPv4 | 2 hosts utilizables por enlace sin desperdicio de difusión |
| RFC 4291 | Arquitectura de Direccionamiento IP Versión 6 | Ámbitos de prefijo de 128 bits, unidifusión global, límite SLAAC /64 |
| RFC 4632 | Enrutamiento Interdominios Sin Clases (CIDR) | Asignaciones de prefijo completas de /0 a /32 con VLSM |
حاسبة شبكات فرعية مجانية لـ IPv4 و IPv6
حاسبة فورية ودقيقة داخل المتصفح لشبكات IPv4 و IPv6 بدون أي تأخير ومعالجة ثنائية محلية بالكامل.