کیلکولیٹر پر جائیں
/24
سب نیٹ کیلکولیٹر
انٹرنیٹ کی تاریخ•9 منٹ کا مطالعہ•8 اکتوبر 2026

IPv4 اور IPv6 کی تاریخ: انٹرنیٹ پروٹوکول کا ارتقاء

ارپانیٹ اور RFC 791 سے لے کر ایڈریس کے خاتمے اور عالمی سطح پر IPv6 کے نفاذ تک کی تاریخ۔

IP
از نیٹ ورک انجینئرنگ ٹیم

1. ARPANET اور IPv4 کا آغاز (1973–1981)

1970 کی دہائی میں ونٹ سرف اور باب کاہن نے TCP/IP بنایا جسے ستمبر 1981 میں RFC 791 کے ذریعے جان پوسٹل نے باضابطہ شکل دی۔

2. IPv4 کے لیے 32 بٹ ایڈریس کا انتخاب کیوں کیا گیا؟

RFC 791 نے ایڈریس کے لیے 32 بٹس مختص کیے جس نے 4.29 ارب منفرد ایڈریس فراہم کیے۔

3. کلاس پر مبنی دور اور ایڈریس کا بحران (1981–1993)

کلاس A, B, C کی بنیاد پر الاٹمنٹ کے باعث کلاس B تیزی سے ختم ہو گئی اور راوٹنگ ٹیبلز بہت بڑے ہو گئے۔

4. وقت کی بچت: CIDR، NAT اور RFC 1918 (1993–1996)

  1. CIDR (RFC 1519): مقررہ حدود ختم کر کے متغیر لمبائی سب نیٹ ماسکنگ (VLSM) متعارف کرائی۔
  2. پرائیویٹ آئی پی ایڈریسز (RFC 1918): اندرونی استعمال کے لیے 10.0.0.0/8, 172.16.0.0/12 اور 192.168.0.0/16 مختص کیے۔
  3. NAT (RFC 1631): ایک عوامی آئی پی کو متعدد ڈیوائسز میں شیئر کرنے کی سہولت فراہم کی۔

5. IPv5 پروٹوکول کے ساتھ کیا ہوا؟

ورژن نمبر 5 تجرباتی Internet Stream Protocol (ST/ST-II) کے لیے رکھا گیا تھا، اس لیے اگلے پروٹوکول کو IPv6 کا نام دیا گیا۔

Version Bit Nibble:
0100 (Binary 4) = IPv4 (RFC 791)
0101 (Binary 5) = ST / ST-II (Internet Stream Protocol - RFC 1190 & RFC 1819)
0110 (Binary 6) = IPv6 (RFC 2460 & RFC 8200)

6. IPv6 کی معیاربندی (1994–1998)

IETF نے 1998 میں RFC 2460 اور 2017 میں RFC 8200 کے تحت IPv6 کو مکمل انٹرنیٹ معیار قرار دیا۔

7. IPv4 ایڈریس کے ختم ہونے کے مراحل

Timeline of IPv4 Exhaustion Milestones:
• Feb 3, 2011:  IANA distributes the final five /8 blocks to the 5 RIRs.
• Apr 15, 2011: APNIC (Asia-Pacific) exhausts standard free pool.
• Sep 14, 2012: RIPE NCC (Europe & Middle East) exhausts free pool.
• Jun 10, 2014: LACNIC (Latin America & Caribbean) exhausts free pool.
• Sep 24, 2015: ARIN (North America) exhausts free pool.
• Nov 25, 2019: RIPE NCC allocates its very last remaining IPv4 block.

8. حال اور مستقبل: ڈوئل اسٹیک اور صرف-IPv6

موبائل آپریٹرز اور جدید کلاؤڈ ڈیٹا سینٹرز 464XLAT کے ذریعے خالص IPv6-Only نیٹ ورکس چلا رہے ہیں۔

ٹیگز:#IPv4 تاریخ#IPv6 ارتقاء#ARPANET#RFC 791#Dual-Stack

⚡سب نیٹ کا حساب لگانے کے لیے تیار ہیں؟

32 بٹ رجسٹر تجزیہ اور سی آئی ڈی آر چارٹس کے ساتھ ہمارا انٹرایکٹو سب نیٹ کیلکولیٹر استعمال کریں۔

سب نیٹ کیلکولیٹر کھولیں →

متعلقہ انجینئرنگ گائیڈز