کیلکولیٹر پر جائیں
/24
سب نیٹ کیلکولیٹر
RFC 5952 & SLAAC

IPv6 سب نیٹ کیلکولیٹر (128-بٹ انجن)

RFC 5952 کے مطابق درست ترین IPv6 کیلکولیٹر بمع کینونیکل کمپریشن اور /64 SLAAC حساب۔

標準 /64 SLAAC
快速 IPv6 預設:

IPv6 子網路與位址範圍摘要:

RFC 5952 壓縮格式 IPv6:
2001:db8:85a3::8a2e:370:7334/64
完整 128 位元展開格式 IPv6:
2001:0db8:85a3:0000:0000:8a2e:0370:7334
網路範圍起點 (Wire ID):
2001:db8:85a3::
網路範圍終點 (最後介面):
2001:db8:85a3::ffff:ffff:ffff:ffff
位址範圍與類型:
عالمی یونیکاسٹ (2000::/3 - عوامی انٹرنیٹ)
標準 /64 子網路容量:
1 (Standard Subnet)
總主機 IP 容量:
18,446,744,073,709,551,616

1. IPv6 128-بٹ ایڈریس آرکیٹیکچر اور درجہ بندی

IPv6 ایڈریس آٹھ 16-بٹ ہیکسادیسیمل بلاکس پر مشتمل ہوتا ہے جنہیں کولن (:) سے الگ کیا جاتا ہے۔

|<------------ 64 Bits ------------>|<------ 64 Bits ------>|
[ عالمی روٹنگ پریفکس (/48) ] [ سب نیٹ شناخت کنندہ (/64) ] [ انٹرفیس آئی ڈی (EUI-64 / SLAAC) ]
  • عالمی روٹنگ پریفکس (/48)
  • سب نیٹ شناخت کنندہ (/64)
  • انٹرفیس آئی ڈی (EUI-64 / SLAAC)

2. اسٹیٹ لیس ایڈریس آٹو کنفیگریشن (SLAAC)

SLAAC (RFC 4862) کو کلائنٹ آٹو کنفیگریشن کے لیے سب نیٹ پر معیاری /64 پریفکس درکار ہوتا ہے۔

SLAAC پر انحصار کرنے والے یوزر سب نیٹس کے لیے کبھی بھی /64 سے لمبا پریفکس استعمال نہ کریں۔

3. راؤٹر پوائنٹ ٹو پوائنٹ لنکس (RFC 6164)

RFC 6164 پنگ پونگ حملوں کی روک تھام کے لیے راؤٹرز کے درمیان /127 پریفکس استعمال کرنے کی ہدایت کرتا ہے۔

آئی پی سب نیٹ آرکیٹیکچر اور بائنری ریاضی گائیڈ