سب نیٹنگ کیا ہے اور براؤزر انجن کیوں استعمال کیا جائے؟
سب نیٹنگ آئی پی نیٹ ورک کو الگ الگ براڈکاسٹ ڈومینز میں تقسیم کرتی ہے، جس سے پتوں کا ضیاع رکتا ہے اور سیکیورٹی بہتر ہوتی ہے۔ براؤزر میں مقامی حساب کتاب 100% رازداری کو یقینی بناتا ہے۔
IPv4 پتے چار 8 بٹ آکٹیٹس میں تقسیم شدہ 32 بائنری بٹس پر مشتمل ہوتے ہیں: نیٹ ورک بٹس اور میزبان بٹس۔
بٹ وائز بولین لاجک: AND, OR اور NOT آپریشنز
03 // بولین
راؤٹرز ہارڈ ویئر لاجک گیٹس کے ذریعے نیٹ ورک کی حدود کا حساب لگاتے ہیں: نیٹ ورک ID = IP AND Mask, براڈکاسٹ = Network OR Wildcard, Wildcard = NOT Mask۔
سب نیٹ ماسک کا مرحلہ وار حساب لگانے کا طریقہ
سابقہ لمبائی کی شناخت کریں، بائنری کو اعشاریہ میں تبدیل کریں، بلاک سائز کا حساب لگائیں اور قابل استعمال میزبان کی حد حاصل کریں۔
کلاؤڈ آرکیٹیکچر میں RFC 1918 پرائیویٹ آئی پی اسپیسز
RFC 3021 /31 پوائنٹ ٹو پوائنٹ لنکس
2 قابل استعمال میزبانوں والے جدید پوائنٹ ٹو پوائنٹ سب نیٹس۔
RFC 1122 /32 سنگل ہوسٹ روٹس
لوپ بیک انٹرفیسز اور وی پی این اینڈ پوائنٹس کے لیے استعمال ہونے والے روٹس۔
آئی پی سب نیٹ آرکیٹیکچر اور بائنری ریاضی گائیڈ
IPv6 ڈوئل اسٹیک →
128-بٹ SLAAC پریفکس کی لمبائی، ایڈریس کی حدود اور RFC 5952 کمپریشن۔
CIDR ٹیبل →
وائلڈ کارڈ ماسک اور بائنری بٹ کی تفصیل کے ساتھ تلاش کے قابل /0 تا /32 جدول۔
کلاؤڈ VPC CIDR پلانر →
کلاؤڈ ریزرو شدہ IP کے ساتھ AWS، Azure اور GCP کے لیے ملٹی AZ سب نیٹس۔
IP رینج کیلکولیٹر →
شروع سے آخر تک IP حدود کا حساب لگائیں اور کم سے کم CIDR بلاکس میں تبدیل کریں۔
سب نیٹنگ گائیڈ اور فارمولے →
مرحلہ وار حل شدہ مثالیں، ریاضیاتی فارمولے اور RFC 3021 /31 لنکس کے اصول۔
سب نیٹ کیلکولیٹر خصوصی سب نیٹ ٹولز اور تفصیلی کیلکولیٹر →
مفت آن لائن IPv4 اور IPv6 سب نیٹ کیلکولیٹر۔ نیٹ ورک ایڈریس، قابل استعمال ہوسٹ رینج، سب نیٹ ماسک اور براڈکاسٹ ایڈریس فوری طور پر معلوم کریں۔