1. Rewolucja przestrzeni adresowej IPv6
Podczas gdy 32-bitowy IPv4 oferował 4,29 miliarda adresów (ostatecznie wyczerpanych przez IANA w 2011 roku), 128-bitowy IPv6 zapewnia ogromną przestrzeń adresową:
2^128 = 340.282.366.920.938.463.463.374.607.431.768.211.456
(~3.4 × 10^38 addresses)
Pojedyncza standardowa podsieć /64 zawiera 18,4 tryliona adresów, trwale eliminując konieczność stosowania mechanizmów translacji NAT.
2. Kanoniczne zasady zapisu RFC 5952
- Pomiń wiodące zera: W każdym bloku 16-bitowym należy usunąć wiodące zera (np.
2001:0db8::0001staje się2001:db8::1). - Kompresja podwójnym dwukropkiem (::): Najdłuższy ciąg zerowych bloków należy skompresować za pomocą
::(maksymalnie raz w adresie). - Rozstrzyganie remisów: W przypadku bloków o tej samej długości kompresuje się pierwszy ciąg.
- Małe litery: Symbole szesnastkowe (a-f) muszą być zapisywane małymi literami.
3. Standardowa hierarchia podsieci IPv6
- /32 Prefiks: Standardowa alokacja RIR dla dostawców internetowych (ISP).
- /48 Prefiks: Standardowa alokacja dla sieci korporacyjnych (65 536 podsieci /64).
- /56 Prefiks: Zalecana alokacja dla małych firm i oddziałów.
- /64 Prefiks: Podstawowy rozmiar podsieci LAN wymagany dla SLAAC (RFC 4862).
4. Strategia Dual-Stack i Happy Eyeballs
Mechanizm Dual-Stack umożliwia równoległe działanie protokołów IPv4 i IPv6 na urządzeniach sieciowych, a algorytm Happy Eyeballs (RFC 8305) automatycznie preferuje połączenia IPv6.