1. एड्रेस स्पेस की तकनीकी क्रांति
जहां 32-बिट IPv4 में केवल 4.29 अरब एड्रेस थे (जो 2011 में IANA पर समाप्त हो गए), वहीं 128-बिट IPv6 असीम क्षमता प्रदान करता है:
2^128 = 340.282.366.920.938.463.463.374.607.431.768.211.456
(~3.4 × 10^38 addresses)
एक अकेला मानक /64 सबनेट 18.4 क्विंटिलियन एड्रेस प्रदान करता है, जिससे NAT की आवश्यकता पूरी तरह समाप्त हो जाती है।
2. RFC 5952 कैनोनिकल निरूपण नियम
- शुरुआती शून्य हटाना:
2001:0db8::0001को2001:db8::1लिखना अनिवार्य है। - डबल कोलन (::) संपीड़न: लगातार शून्य वाले सबसे लंबे ब्लॉक को पते में केवल एक बार
::से छोटा किया जाता है। - लोअरकेस अक्षर: हेक्साडेसिमल अक्षर (a–f) केवल छोटे अक्षरों में लिखे जाने चाहिए।
3. IPv6 सबनेट पदानुक्रम
- /32: RIR द्वारा इंटरनेट सेवा प्रदाताओं (ISP) को मानक आवंटन।
- /48: कॉर्पोरेट उद्यमों को मानक आवंटन (65,536 स्वतंत्र /64 सबनेट प्रदान करता है)।
- /64: हर स्थानीय लैन (LAN) सबनेट का मानक आकार (SLAAC - RFC 4862 हेतु अनिवार्य)।
4. डुअल-स्टैक रणनीति
एक ही नेटवर्क इंटरफ़ेस पर IPv4 और IPv6 दोनों समानांतर चलते हैं। Happy Eyeballs (RFC 8305) एल्गोरिदम प्राथमिकता से IPv6 कनेक्शन बनाता है।