1. Революція адресного простору
В то время как 32-битный IPv4 предоставлял всего 4,29 миллиарда адресов (полностью исчерпанных IANA в 2011 году), 128-битный IPv6 открывает практически бесконечное адресное пространство:
2^128 = 340.282.366.920.938.463.463.374.607.431.768.211.456
(~3.4 × 10^38 addresses)
Одна стандартная подсеть /64 содержит 18,4 квинтиллиона адресов, навсегда избавляя сеть от ограничений NAT.
2. Канонические правила записи RFC 5952
- Удаление ведущих нулей:
2001:0db8::0001записывается исключительно как2001:db8::1. - Сжатие двойным двоеточием (::): Самая длинная непрерывная группа нулевых 16-битных блоков сжимается в
::(ровно один раз в адресе). - Строчные буквы: Шестнадцатеричные символы (a–f) всегда пишутся в нижнем регистре.
3. Иерархия подсетей IPv6
- /32: Стандартный блок, выделяемый RIR интернет-провайдерам (ISP).
- /48: Стандартный блок для корпоративных сетей (содержит 65 536 подсетей /64).
- /64: Стандартный размер любой локальной сети (обязателен для SLAAC, RFC 4862).
- /128: Одиночный хост или интерфейс loopback.
4. Стратегия Dual-Stack
В режиме Dual-Stack протоколы IPv4 и IPv6 работают параллельно на одном интерфейсе. Алгоритм Happy Eyeballs (RFC 8305) автоматически пробует соединение по IPv6 с мгновенным переключением на IPv4 при задержках.