कैलकुलेटर पर जाएं
/24
सबनेट कैलकुलेटर
RFC 5952 & SLAAC

IPv6 सबनेट कैलकुलेटर (128-बिट डुअल-स्टैक इंजन)

RFC 5952 संपीड़न, पूर्ण 128-बिट विस्तार और /64 SLAAC गणना के साथ उच्च-सटीक IPv6 कैलकुलेटर।

मानक /64 SLAAC
त्वरित IPv6 प्रीसेट:

IPv6 सबनेट और रेंज सारांश:

RFC 5952 संपीड़ित IPv6:
2001:db8:85a3::8a2e:370:7334/64
पूर्ण 128-बिट विस्तारित IPv6:
2001:0db8:85a3:0000:0000:8a2e:0370:7334
नेटवर्क रेंज प्रारंभ (वायर ID):
2001:db8:85a3::
नेटवर्क रेंज अंत (अंतिम इंटरफ़ेस):
2001:db8:85a3::ffff:ffff:ffff:ffff
पता दायरा और प्रकार:
ग्लोबल यूनिकास्ट (2000::/3 - सार्वजनिक इंटरनेट)
मानक /64 सबनेट क्षमता:
1 (Standard Subnet)
कुल होस्ट आईपी क्षमता:
18,446,744,073,709,551,616

1. IPv6 128-बिट पता संरचना और पदानुक्रम

IPv6 पता कोलन (:) द्वारा अलग किए गए आठ 16-बिट हेक्साडेसिमल ब्लॉकों से बना होता है।

|<------------ 64 Bits ------------>|<------ 64 Bits ------>|
[ वैश्विक रूटिंग उपसर्ग (/48) ] [ सबनेट पहचानकर्ता (/64) ] [ इंटरफ़ेस आईडी (EUI-64 / SLAAC) ]
  • वैश्विक रूटिंग उपसर्ग (/48)
  • सबनेट पहचानकर्ता (/64)
  • इंटरफ़ेस आईडी (EUI-64 / SLAAC)

2. स्टेटलेस एड्रेस ऑटो-कॉन्फ़िगरेशन (SLAAC)

SLAAC (RFC 4862) को क्लाइंट ऑटो-कॉन्फ़िगरेशन के लिए सबनेट पर मानक /64 उपसर्ग की आवश्यकता होती है।

SLAAC पर निर्भर उपयोगकर्ता सबनेट के लिए कभी भी /64 से लंबे उपसर्ग का उपयोग न करें।

3. राउटर-टू-राउटर पॉइंट-टू-पॉइंट लिंक (RFC 6164)

RFC 6164 पिंग-पॉन्ग हमलों को रोकने के लिए राउटर इंटरकनेक्ट के लिए /127 उपसर्ग निर्धारित करता है।

आईपी सबनेट आर्किटेक्चर और बिटवाइज़ इंजीनियरिंग गाइड