Перейти до калькулятора
/24
Калькулятор підмереж
RFC 5952 & SLAAC

Калькулятор підмереж IPv6 (128-бітний движок)

Високоточний калькулятор IPv6 з канонічним стисненням за RFC 5952 і межами /64 SLAAC.

Стандартний /64 SLAAC
Швидкі пресети IPv6:

Зведення підмережі та діапазону IPv6:

RFC 5952 Стислий IPv6:
2001:db8:85a3::8a2e:370:7334/64
Повний 128-бітний розширений IPv6:
2001:0db8:85a3:0000:0000:8a2e:0370:7334
Початок діапазону мережі (Wire ID):
2001:db8:85a3::
Кінець діапазону мережі (останній інтерфейс):
2001:db8:85a3::ffff:ffff:ffff:ffff
Область дії та тип адреси:
Глобальний Unicast (2000::/3 - Публічний Інтернет)
Ємність стандартних підмереж /64:
1 (Standard Subnet)
Загальна ємність адрес вузлів:
18,446,744,073,709,551,616

1. 128-бітна архітектура та ієрархія адрес IPv6

Адреси IPv6 складаються з восьми 16-бітних шістнадцяткових блоків, розділених двокрапками.

|<------------ 64 Bits ------------>|<------ 64 Bits ------>|
[ Префікс глобальної маршрутизації (/48) ] [ Ідентифікатор підмережі (/64) ] [ Ідентифікатор інтерфейсу (EUI-64 / SLAAC) ]
  • Префікс глобальної маршрутизації (/48)
  • Ідентифікатор підмережі (/64)
  • Ідентифікатор інтерфейсу (EUI-64 / SLAAC)

2. Безсерверне автоналаштування адрес (SLAAC)

SLAAC (RFC 4862) вимагає довжину префікса /64 для автоматичної адресації клієнтів.

Ніколи не використовуйте префікси довші ніж /64 для підмереж користувачів, які покладаються на SLAAC.

3. З'єднання «точка-точка» (RFC 6164)

RFC 6164 визначає префікси /127 для каналів між маршрутизаторами для захисту від атак «пінг-понг».

Архітектура IP-підмереж та посібник з двійкових операцій