Τι είναι το Subnetting και γιατί να χρησιμοποιήσετε μηχανισμό στο πρόγραμμα περιήγησης;
Το subnetting χωρίζει ένα δίκτυο IP σε απομονωμένα broadcast domains, αποτρέποντας τη σπατάλη διευθύνσεων και ενισχύοντας την ασφάλεια. Ο υπολογισμός στο πρόγραμμα περιήγησης εγγυάται 100% απόρρητο.
Οι διευθύνσεις IPv4 αποτελούνται από 32 δυαδικά bits χωρισμένα σε τέσσερα octets των 8 bits: bits δικτύου και bits κεντρικού υπολογιστή.
Λογική Boole σε Επίπεδο Bit: Πράξεις AND, OR και NOT
03 // BOOLEAN
Οι δρομολογητές υπολογίζουν τα όρια δικτύου μέσω λογικών πυλών: Network ID = IP AND Mask, Broadcast = Network OR Wildcard, Wildcard = NOT Mask.
Βήμα προς Βήμα Μεθοδολογία Υπολογισμού Μάσκας Υποδικτύου
Προσδιορίστε το μήκος του προθέματος, μετατρέψτε τα δυαδικά octets σε δεκαδικά, υπολογίστε το μέγεθος του μπλοκ και εξάγετε το εύρος διευθύνσεων και τη διεύθυνση broadcast.
Ιδιωτικοί Χώροι Διευθύνσεων IP RFC 1918 στο Cloud
RFC 3021 /31 Συνδέσεις Σημείο-προς-Σημείο
Σύγχρονα υποδίκτυα σημείο-προς-σημείο με 2 χρησιμοποιήσιμους υπολογιστές.
RFC 1122 /32 Διαδρομές Μεμονωμένου Υπολογιστή
Διαδρομές μεμονωμένου υπολογιστή για διασυνδέσεις loopback και τερματικά VPN.
Οδηγός Αρχιτεκτονικής Υποδικτύων IP & Δυαδικών Πράξεων
IPv6 Dual-Stack →
Μήκη προθεμάτων SLAAC 128-bit, εύρη διευθύνσεων και συμπίεση κατά RFC 5952.
Πίνακας CIDR →
Πίνακας με δυνατότητα αναζήτησης από /0 έως /32 με μάσκες μπαλαντέρ και δυαδική ανάλυση bit.
Σχεδιαστής CIDR για Cloud VPC →
Υποδίκτυα Multi-AZ για AWS, Azure και GCP με υπολογισμό δεσμευμένων IP στο cloud.
Υπολογιστής Εύρους IP →
Υπολογίστε εύρη IP από την αρχή έως το τέλος και μετατρέψτε τα σε ελάχιστα μπλοκ CIDR.
Οδηγός Υποδικτύων & Τύποι →
Παραδείγματα βήμα προς βήμα, μαθηματικοί τύποι και προδιαγραφές RFC 3021 /31.
Υπολογιστής Υποδικτύου Εξειδικευμένα Εργαλεία Υποδικτύωσης & Υπολογιστές Αρχιτεκτονικής →
Δωρεάν online υπολογιστής υποδικτύου IPv4 και IPv6. Υπολογίστε άμεσα διευθύνσεις δικτύου, εύρη χρησιμοποιήσιμων υπολογιστών, μάσκες υποδικτύου και διευθύνσεις εκπομπής.