מהו חלוקת רשתות משנה ומדוע להשתמש במחשבון מבוסס דפדפן?
חלוקת רשתות משנה מפצלת רשת IP למתחמי שידור מבודדים, מונעת בזבוז כתובות ומשפרת את האבטחה. חישוב מקומי בדפדפן מבטיח 100% פרטיות לתוכניות הרשת שלך.
כתובות IPv4 מורכבות מ-32 סיביות בינאריות המחולקות לארבעה אוקטטים של 8 סיביות: סיביות רשת וסיביות מארח.
לוגיקה בוליאנית ברמת הסיביות: פעולות AND, OR ו-NOT
03 // בוליאני
נתבים מחשבים גבולות רשת באמצעות שערים לוגיים: מזהה רשת = IP AND Mask, שידור = Network OR Wildcard, מסכת Wildcard = NOT Mask.
מתודולוגיית חישוב מסכת רשת משנה צעד אחר צעד
זהה את אורך הקידומת, המר אוקטטים בינאריים לעשרוניים, חשב את גודל הבלוק וחלץ את טווח המארחים הזמין וכתובת השידור.
טווחי IP פרטיים של RFC 1918 בארכיטקטורת ענן
RFC 3021 /31 קישורי נקודה לנקודה
רשתות משנה מודרניות מנקודה לנקודה עם 2 מארחים שמישים ללא בזבוז שידור.
RFC 1122 /32 ניתובי מארח יחיד
ניתובי מארח יחיד המשמשים לממשקי loopback ולנקודות קצה של VPN.
מדריך ארכיטקטורת סאבנט IP ומתמטיקה בינארית
IPv6 כפול →
אורכי קידומת SLAAC ברוחב 128 סיביות, טווחי כתובות ודחיסה תקנית לפי RFC 5952.
טבלת CIDR →
טבלה ניתנת לחיפוש מ-/0 עד /32 עם מסיכות Wildcard ופירוק סיביות בינארי.
מתכנן CIDR עבור Cloud VPC →
סאבנטים מרובי אזורי זמינות עבור AWS, Azure ו-GCP עם התחשבות בכתובות IP שמורות.
מחשבון טווח IP →
חשב טווחי כתובות IP מההתחלה ועד הסוף והמר אותם לבלוקי CIDR מינימליים.
מדריך רשתות משנה ונוסחאות →
דוגמאות מפורטות שלב אחר שלב, נוסחאות מתמטיות ומפרטי RFC 3021 /31.
מחשבון סאבנט כלי סאבנטינג ייעודיים ומחשבונים מתקדמים →
מחשבון סאבנט מקוון בחינם עבור IPv4 ו-IPv6. חשב כתובות רשת, טווח כתובות מארחים שמישות, מסכות רשת וכתובות שידור באופן מיידי בדפדפן.