சப்நெட்டிங் என்றால் என்ன, உலாவி எஞ்சினை ஏன் பயன்படுத்த வேண்டும்?
சப்நெட்டிங் ஒரு IP நெட்வொர்க்கை தனித்தனி பிராட்காஸ்ட் டொமைன்களாகப் பிரித்து, முகவரி வீணாவதைத் தடுக்கிறது மற்றும் பாதுகாப்பை மேம்படுத்துகிறது. உலாவியில் கணக்கிடுவது 100% தனியுரிமையை உறுதி செய்கிறது.
IPv4 முகவரிகள் நான்கு 8-பிட் ஆக்டெட்டுகளாக பிரிக்கப்பட்ட 32 பைனரி பிட்களைக் கொண்டிருக்கின்றன: நெட்வொர்க் பிட்கள் மற்றும் ஹோஸ்ட் பிட்கள்.
பிட்வைஸ் பூலியன் லாஜிக்: AND, OR மற்றும் NOT செயல்பாடுகள்
03 // பூலியன்
ரൂട്ടர்கள் வன்பொருள் வாயில்கள் மூலம் நெட்வொர்க் எல்லைகளைக் கணக்கிடுகின்றன: நெட்வொர்க் ஐடி = IP AND Mask, பிராட்காஸ்ட் = Network OR Wildcard, Wildcard = NOT Mask.
சப்நெட் மாஸ்க்கை படிப்படியாக கணக்கிடும் முறை
முன்னொட்டு நீளத்தை அடையாளம் கண்டு, பைனரி ஆக்டெட்டுகளை தசமமாக மாற்றி, பிளாக் அளவைக் கணக்கிட்டு, பயன்படுத்தக்கூடிய ஹோஸ்ட் வரம்பைப் பெறுங்கள்.
கிளவுட் கட்டமைப்பில் RFC 1918 தனியார் IP இடைவெளிகள்
RFC 3021 /31 பாயிண்ட்-டு-பாயிண்ட் இணைப்புகள்
2 பயன்படுத்தக்கூடிய ஹோஸ்ட்களுடன் கூடிய நவீன பாயிண்ட்-டு-பாயிண்ட் சப்நெட்டுகள்.
RFC 1122 /32 ஒற்றை ஹோஸ்ட் வழிகள்
லூப்பேக் இடைமுகங்கள் மற்றும் VPN இறுதிப்புள்ளிகளுக்குப் பயன்படுத்தப்படும் வழிகள்.
ஐபி சப்நெட் கட்டமைப்பு & பைனரி வழிகாட்டி
IPv6 டூயல்-ஸ்டாக் →
128-பிட் SLAAC முன்னொட்டு நீளங்கள், முகவரி வரம்புகள் மற்றும் RFC 5952 சுருக்க முறை.
CIDR அட்டவணை →
வைல்ட்கார்டு மாஸ்க்குகள் மற்றும் பைனரி பிட் பிரிவுகளுடன் தேடக்கூடிய /0 முதல் /32 அட்டவணை.
கிளவுட் VPC CIDR திட்டமிடுபவர் →
கிளவுட் ஒதுக்கப்பட்ட IPகளுடன் AWS, Azure மற்றும் GCP-க்கான பல AZ சப்நெட்டுகள்.
IP வரம்பு கால்குலேட்டர் →
தொடக்கத்திலிருந்து இறுதி வரையிலான IP வரம்புகளைக் கணக்கிட்டு குறைந்தபட்ச CIDR தொகுதிகளாக மாற்றவும்.
சப்நெட்டிங் வழிகாட்டி & சூத்திரங்கள் →
படிப்படியான எடுத்துக்காட்டுகள், கணித சூத்திரங்கள் மற்றும் RFC 3021 /31 விவரக்குறிப்புகள்.
சப்நெட் கால்குலேட்டர் சிறப்பு சப்நெட்டிங் கருவிகள் & ஆழமான கால்குலேட்டர்கள் →
இலவச ஆன்லைன் IPv4 மற்றும் IPv6 சப்நெட் கால்குலேட்டர். பிணைய முகவரிகள், பயன்படுத்தக்கூடிய ஹோஸ்ட் வரம்புகள், சப்நெட் முகமூடிகள் மற்றும் ஒளிபரப்பு முகவரிகளை உடனுக்குடன் கணக்கிடுங்கள்.