Hoppa till Kalkylatorn
/24
Subnätkalkylator
RFC 5952 & SLAAC

IPv6 Subnätkalkylator (128-bitars motor)

Högprecisionskalkylator för IPv6 enligt RFC 5952 med kanonisk komprimering och /64 SLAAC-beräkning.

Standard /64 SLAAC
Snabba IPv6-Förinställningar:

IPv6 Subnät- & Intervallsammanfattning:

RFC 5952 Komprimerad IPv6:
2001:db8:85a3::8a2e:370:7334/64
Fullständig 128-Bitars Expanderad IPv6:
2001:0db8:85a3:0000:0000:8a2e:0370:7334
Nätverksintervall Start (Wire ID):
2001:db8:85a3::
Nätverksintervall Slut (Sista Gränssnitt):
2001:db8:85a3::ffff:ffff:ffff:ffff
Adressomfång och Typ:
Global Unicast (2000::/3 - Publikt Internet)
Kapacitet för Standard /64 Subnät:
1 (Standard Subnet)
Total Värd-IP-Kapacitet:
18,446,744,073,709,551,616

1. 128-Bitars IPv6-Adressarkitektur & Hierarki

IPv6-adresser består av åtta 16-bitars hexadecimala block separerade med kolon.

|<------------ 64 Bits ------------>|<------ 64 Bits ------>|
[ Globalt Ruttprefix (/48) ] [ Subnäts-ID (/64) ] [ Gränssnittsidentifierare (EUI-64 / SLAAC) ]
  • Globalt Ruttprefix (/48)
  • Subnäts-ID (/64)
  • Gränssnittsidentifierare (EUI-64 / SLAAC)

2. Automatisk Adresskonfiguration utan Tillstånd (SLAAC)

SLAAC (RFC 4862) kräver en prefixlängd på /64 för automatisk adressering av klienter.

Använd aldrig prefix längre än /64 för användardelvätverk som förlitar sig på SLAAC.

3. Punkt-till-Punkt-länkar (RFC 6164)

RFC 6164 specificerar /127-prefix för routerförbindelser för att förhindra ping-pong-attacker.

Guide till IP-subnätarkitektur & binär matematik