కాలిక్యులేటర్‌కు దాటవేయి
/24
సబ్‌నెట్ కాలిక్యులేటర్
RFC 5952 & SLAAC

IPv6 సబ్‌నెట్ కాలిక్యులేటర్ (128-బిట్ ఇంజిన్)

RFC 5952 కంప్రెషన్ మరియు /64 SLAAC సరిహద్దు గణనతో కూడిన IPv6 కాలిక్యులేటర్.

ప్రామాణిక /64 SLAAC
శీఘ్ర IPv6 ప్రీసెట్‌లు:

IPv6 సబ్‌నెట్ & పరిధి సారాంశం:

RFC 5952 సంక్షిప్త IPv6:
2001:db8:85a3::8a2e:370:7334/64
పూర్తి 128-బిట్ విస్తరించిన IPv6:
2001:0db8:85a3:0000:0000:8a2e:0370:7334
నెట్‌వర్క్ శ్రేణి ప్రారంభం (వైర్ ID):
2001:db8:85a3::
నెట్‌వర్క్ శ్రేణి ముగింపు (చివరి ఇంటర్‌ఫేస్):
2001:db8:85a3::ffff:ffff:ffff:ffff
చిరునామా పరిధి & రకం:
గ్లోబల్ యూనిక్యాస్ట్ (2000::/3 - పబ్లిక్ ఇంటర్నెట్)
ప్రామాణిక /64 సబ్‌నెట్‌ల సామర్థ్యం:
1 (Standard Subnet)
మొత్తం హోస్ట్ IP సామర్థ్యం:
18,446,744,073,709,551,616

1. IPv6 128-బిట్ అడ్రస్ ఆర్కిటెక్చర్ మరియు క్రమానుగత నిర్మాణం

IPv6 చిరునామా కోలన్ (:) తో వేరు చేయబడిన ఎనిమిది 16-బిట్ హెక్సాడెసిమల్ బ్లాక్‌లను కలిగి ఉంటుంది.

|<------------ 64 Bits ------------>|<------ 64 Bits ------>|
[ గ్లోబల్ రూటింగ్ ప్రిఫిక్స్ (/48) ] [ సబ్‌నెట్ ఐడెంటిఫైయర్ (/64) ] [ ఇంటర్‌ఫేస్ ఐడి (EUI-64 / SLAAC) ]
  • గ్లోబల్ రూటింగ్ ప్రిఫిక్స్ (/48)
  • సబ్‌నెట్ ఐడెంటిఫైయర్ (/64)
  • ఇంటర్‌ఫేస్ ఐడి (EUI-64 / SLAAC)

2. స్టేట్‌లెస్ అడ్రస్ ఆటో-కాన్ఫిగరేషన్ (SLAAC)

SLAAC (RFC 4862) క్లయింట్ ఆటో-కాన్ఫిగరేషన్ కోసం సబ్‌నెట్‌పై ప్రామాణిక /64 ప్రిఫిక్స్‌ను తప్పనిసరి చేస్తుంది.

SLAAC పై ఆధారపడే యూజర్ సబ్‌నెట్‌ల కోసం ఎప్పుడూ /64 కంటే పెద్ద ప్రిఫిక్స్‌ను ఉపయోగించవద్దు.

3. రూటర్ పాయింట్-టు-పాయింట్ లింక్‌లు (RFC 6164)

పింగ్-పాంగ్ దాడులను నిరోధించడానికి రౌటర్ ఇంటర్‌కనెక్ట్‌ల కోసం RFC 6164 /127 ప్రిఫిక్స్‌ను నిర్దేశిస్తుంది.

IP సబ్‌నెట్ ఆర్కిటెక్చర్ & బిట్‌వైజ్ ఇంజనీరింగ్ గైడ్